Компания Dell N4110 тачпад вдруг перестал работать

Я использую Ubuntu 11.10 64 bit и мой тачпад на Dell N4110 вдруг перестал работать.

Я проверил мышь и сенсорная панель настроек и тачпад не отключается. Что я должен делать?

+790
tim reibsamen 1 янв. 2016 г., 17:13:27
36 ответов

Многое изменилось с 11.04 и Compiz более интегрированы в 11.10. Некоторые варианты, где верно 11.04 не вариант уже в 11.10.

Если вы действительно хотите играть в игры в Linux моя рекомендация-это будет всегда, пока NVIDIA и ATI релиз хороших стабильных драйверов: нет эффекты рабочего стола, если вы играете в игры.

Только представьте, сколько миллисекунд, что вы в безопасности (и, следовательно, допустить, что выстрел в голову вызовет у вас засек снайпера на время) без компьютера посчитать, какой это замечательный 3D-эффект на эти кнопки может выглядеть?

Можно краткий ответ будет: не используйте 3D рабочий стол для игры, особенно в 11.10, его так много тяжелой графики.

+983
Avestron 03 февр. '09 в 4:24

Привет, я пытаюсь установить окно gedit плагин под названием зум, и для того, чтобы быть подхвачена теперь он должен быть извлечен в эту папку в/usr/lib в/Редакторе gedit-2/плагинов.

Моя проблема я не могу скопировать и вставить файлы в этот каталог. Я попытался изменить разрешения на папку, но он говорит: "Вы не являетесь владельцем, поэтому вы не можете изменить эти разрешения".

Как я могу исправить это?

+903
davidbitton 3 апр. 2011 г., 19:41:25
Другие ответы

Связанные вопросы


Похожие вопросы

Не совсем как клавиши Ctrlклавишу AltDel в Windows, но вы можете также убить с xkill. Просто зайдите в "выполнить" диалоговое окно (Альт+Ф2), тип в xkill и указатель мыши изменится на "х". Точки на приложение, которое вы хотите убить и нажмите кнопку, и он будет убит. Иногда можно намного быстрее, чем загрузка системы мониторинга.

+894
damon chen 24 мая 2015 г., 03:16:10

Если после установки некоторых пакетов на веб-сайте , я был интересно, если это возможно, чтобы иметь автоматическое уведомление, когда обновление доступно, так как эти пакеты в репозиториях Ubuntu.

Может пакеты быть загружен в деб форме, или даже в исходном коде?

Например,

  1. nevernote поддерживается в SourceForge,что http://nevernote.sourceforge.net/index.htm, загрузить с http://sourceforge.net/projects/nevernote/files/Current/nevernote-0.99_i386.deb/download
  2. пакеты от Ubuntu ППА https://launchpad.net/ubuntu/+ППД.
+883
badji2009 7 февр. 2014 г., 10:50:25

11.10 и предыдущие

видео может использоваться для преобразования .в ОГВ .формат WebM напрямую, без необходимости в дополнительных кодеках. Как уже упоминалось в комментарии на другой ответ, версия ffmpeg на поставленный Ubuntu не приходят по умолчанию с кодеками, которые могут представлять программного обеспечения патентных вопросов.

Это программа командной строки; чтобы его использовать, просто откройте окно терминала и введите:

пакет ffmpeg -I вход.выход Буо.в WebM
+863
Claudia Malo 24 мар. 2017 г., 16:52:35

Я имел эту проблему, и, к сожалению, это действительно проблема с Yahoo инфраструктуры, и не столько что-то не так с сочувствием (другими словами, вы не сможете остановить боль от думая, что вы истинный друг просит).

Лучшее, что я могу предложить вам, чтобы сообщить о хотелках ошибку на сочувствие :(. Вы могли бы попробовать пиджин, но в моей памяти, что не делает ее слишком много, легче уволить контакте спам на одном дыхании, хотя она справиться с этим лучше, чем сочувствие.

Как мрачно, как это звучит, я также предлагаю отойдя от Yahoo для чата.

+780
Tech Inspiration 28 июн. 2016 г., 05:25:40

Возможно, Вам потребуется установить MS основные шрифты.

судо apt-получить установку msttcorefonts
+775
James Kemp 26 янв. 2020 г., 08:47:20

Это действительно вопрос личных предпочтений.

В не-LTS релизы, которые также состоит из некоторые .04 релизы имеют более короткие периоды поддержки, но часто имеют "новые" возможности, которые LTS-релизы не.

Для меня, как правило, обновить себя до последней на мой личный основной ноутбук, перейдите к тестированию на моем ноутбуке тестирования и в зависимости от возможности остаться на LTS для серверов. Для моей работы ноутбук я обычно обновить до последнего, но я не всегда успеваю это сделать сразу после освобождения.

В резюме:

Если вы хотите стабильности и не хотите, долгосрочная поддержка тогда идите с ЛЦ

Если вы хотите режущей кромки, но все-таки стабильный, идут с последней версией

+763
piotrek 3 апр. 2013 г., 02:52:10

Я обнаружил, что вы можете использовать установщик при установке новых НПА.

Точное ППА

https://launchpad.net/~fmarier/+архив/ГИТ-приложение

Новую версию git-приложение, включая помощника и веб-приложений. (Поддерживается Франсуа Marier)

судо дополнения кв-репозиторий PPA:fmarier/ГИТ-приложение
судо apt-получить обновление
суда apt-получить установку ГИТ-приложение

см http://git-annex.branchable.com/install/Ubuntu/

+733
Eikkiv 4 февр. 2010 г., 14:24:17

Приятно, спасибо за все ответы!

Я также нашел программу под названием сейчас. Поэтому люди голосуют, какой вариант вы рекомендуете больше?

http://en.wikipedia.org/wiki/Kexi

Kexi Screenshot

+728
pitbul 27 окт. 2018 г., 11:59:27

Из моего личного опыта с несколько беспроводных карт. Лучшие карты руки вниз на рабочем столе-это карты Интел центрино. Все остальные карты были проблемы со стабильностью соединения и значительно более низких скоростях. В конце концов я понял, что мой ноутбук никогда не было этих проблем, которые побудили меня, чтобы определить драйвер и аппаратное обеспечение используется для беспроводной сети. Я обнаружил, что ноутбук использует чип Intel процессором Centrino, которая используется драйвер iwlwifi. Быстрый поиск Google для карты Intel Centrino для настольных ПК и $25 позже, у меня было быстрое и стабильное подключение к интернету с помощью драйвера iwlwifi. На быстрый и стабильный в смысле, нет отключений никогда, и со скоростью передачи данных до 54 Мбит / с на расстоянии трех номеров по горизонтали и этажом ниже беспроводных маршрутизатора. Ни один другой производитель карты, которые я использовал и даже приблизиться к такой скорости на рабочем столе.

+723
mreppy 27 июл. 2017 г., 02:16:02

Я искал на разных форумах, как подключиться к сети с WPA с терминала, но ни один, кажется, работает

В сети managager файл "/etc/диспетчер связи/системы связи/elhackerderivendel" у меня есть:

[связь]
ИД=elhackerderivendel
идентификатор UUID=2ec1e3d4-31ea-4d08-9aa4-6afc82324186
тип=802-11-беспроводной
типа timestamp=1322936420

[802-11-беспроводной]
имя SSID=elhackerderivendel
режим=инфраструктуру
MAC-адрес=ас:81:12:ББ:28:е
безопасности=802-11-беспроводной интернет-безопасности

[802-11 интернет-безопасности]
ключ-упр=ВПА-ПСК
ПСК=АААААААААААААААА #это не мой настоящий пароль, как вы можете ожидать

[протокол IPv4]
способ=авто

[протокол IPv6]
способ=авто

А с другой стороны iwconfig говорит мне

- Устройство: как wlan0 [elhackerderivendel] ------------------------------------------
 Тип: 802.11 Беспроводной Доступ В Интернет
 Водитель: brcmsmac
 Состояние: подключен
 По умолчанию: да
 Х. В., адрес: переменного тока:81:12:ББ:28:0Е

Возможности:
 Скорость: 28 Мб/с

 Свойства Беспроводной Сети
 WEP-шифрование: да
 Шифрование WPA: да
 WPA2 шифрования: да

И sudo scan_results используя wpa_cli

Выбранный интерфейс 'как wlan0'
МАС-адрес / частота уровень / сигнала / флаги / имя SSID
00:0е:2е:С2:11:00 2462 188 [шифрованием WPA2-ПСК-САМПР-preauth][ЭСС] elhackerderivendel
00:0В:3б:чч:95:Е4 2427 177 [шифрованием WPA2-ПСК-САМПР][ВЭС][ЭСС] elhackerderivendel

Любая идея, что написать в файле wpa_supplicant.конф?

+676
Chengzhong SHEN 24 апр. 2014 г., 19:17:37

В общем, вы можете установить программное обеспечение с жесткого диска через GUI под названием "APTonCD". Но для этого вам понадобится система С приложение на нем в первую очередь. Стоит проверить, если я понимаю ваш вопрос. Вы можете создать компакт-диска, а затем ISO на жесткий диск. Я не использовал "APTonCD", поэтому я не уверен, какие варианты он вам дает. Это может позволяют сохранить приложения на жесткий диск в первую очередь. К сожалению, я не слишком конкретно. Просто давая вам возможность исследовать.

+670
user2999403 23 мая 2018 г., 07:22:04

Ок, у меня была такая же проблема, вот как я это исправил.

С помощью http://www.sane-project.org/README.linux

Прежде всего, отключите сканер, и начать все заново. Я удалил как xsane, и все, что связано через синаптическую. Я также удалил все, что было настроено и сделать установки по вменяемым-бэкэнд-ГИТ.
Вы делаете это так:

 $ компакт-дисков [ваш вменяемый-бэкэнд-ГИТ папку]
 $ судо сделать удаление

После этого я проверил wheter или не имел каких-либо libsane.так.1 слева, (и любые другие архивы, относящиеся к вменяемым).

 судо найти / -имя libsane.так.1

Ок , все понятно.

Установка Примечание снова с синаптической, и некоторых зависимостей

как xsane 0.998-3ubuntu2 
libsane 1.0.22-7ubuntu1
libsane-общие 1.0.22-7ubuntu1
Примечание-общие 0.998-3ubuntu2
вменяемый-utils версии 1.0.22-7ubuntu1

тестирование выход команды scanimage -в, просто для удовольствия

утилита scanimage (санэ-бэкэндов). 1.0.22; серверная версия 1.0.22

Следующие шаги, судя по ридми.Линукс 1.0.24.документация ГИТ.

сначала найдите libsane.так.1

судо найти / -имя libsane.так.1

И, в зависимости от вашей системы, обратите внимание на папку, где libsane.так.1 находится. В моем случае:

в /usr/lib в/для i386-линукс-дистрибутив GNU/libsane.так.1

тогда, с вашего вменяемый-бэкэнд-ГИТ папку

./настроить 2>&1 | тройник ~/thiscommandwritesalogfiletoyourhomefolder.журнал

В 2>&1 | TEE и пишет лог-файл, где вы его определяете. Что может пригодиться, хотя и не обязан. Пожалуйста, проверьте вывод настроить, что USB поддерживается. Эту информацию поставляется с одной из последних строчек. Если нет, то вам нужно установить библиотеки libusb-Дев теперь и повторно настроить.

установите вменяемые-Git в /usr/местные/библиотека/

$ делает && установка

Затем одна из самых важных частей, создание символической ссылки. Обратите внимание, что здесь вам придется изменить имя папки на ту, где libsane.так.1 находится. (см. выше как это сделать)

$ кд /usr/lib в/для i386-Линукс-гну
$ судо ЛН-СФ /usr/местные/библиотека/libsane.так.1.0.24 libsane.так.1
$ судо ЛН-СФ /usr/местные/библиотека/вменяемый/libsane.Ла-libsane.Ла
$ компакт -


правила udev скопировать файл
$ судо СР инструменты/udev из/libsane.правил файл /etc/udev из/правил.д

подключите сканер к шине USB

присоединяйтесь к сканеру группы

команду adduser судо [вы] санэд
команду adduser судо [вы] сканер 

и выхода из системы и войти снова

что должен делать это. утилита scanimage -В должны дать последнюю libsane бэкэнд, и xsane должен работать без проблем.

Надеюсь, что это помогло вам.

И обратите внимание, если у вас есть проблемы с Примечание выключением, просто удалить в домашней папке скрытый файл .вменяемый, тип клавиш Ctrl-ч в Наутилус, и вы найдете его.

+589
pd176 20 окт. 2011 г., 20:56:52

Я установил встроенных машин Amazon изображения с в RStudio Server, предоставляемых по программе bioconductor в бесплатный микро-экземпляр на EC2.
Затем я установил зубцы (просто еще один Гиббс сэмплер , чтобы использовать его в RStudio через сервер.
Для этого я просто использовал в RStudio Server в консоли команду sudo apt-получить установку зубцы , которые хорошо работали, насколько я могу сказать (если я запускаю его снова, он говорит мне, зубцы вверх-к-дата).

Однако, когда я пытался установить пакет "rjags", который является интерфейсом между RStudio и зубцы по biocLite("rjags") или установите.пакеты("rjags"), это не удалось с сообщением об ошибке

проверка jags_version в ljags... да
настроить: ошибка: "зубцы модуль каталог /usr/lib64/зубцы/модулей-3 не существует".
Ошибка: сбой настройки для пакета ‘rjags’
* удаление ‘/дом/Убунту/Р/библиотеки/rjags’
Предупреждение в установке.пакеты :
 установка пакета ‘rjags’ имел ненулевой статус выхода 

Я проверил в lib64 и, действительно, есть только в каталоге "ягуары" с "зазубринами-терминал", как и ее содержание.

Я был бы признателен за любые указатели, я думаю, очевидно, что я был включен, чтобы сделать что-то за гранью моего понимания благодаря большому учебники.

+585
How 2 авг. 2014 г., 18:06:07

Программа заботится о том, что это жратва. Вы можете ввести жратвы, удерживая сдвиг при загрузки компьютера. Там вы должны быть в состоянии выбрать Windows или Linux.

Если вы хотите всегда видеть в grub меню, попробуйте изменить тайм-аут, как это хорошо описано, например, этот пост на Linuxpoison

+582
Swadhin Jadhav 27 окт. 2016 г., 19:52:13

Работает с ... нет-бин-ссылки на меня:

НПМ установки-нет-Бен-ссылки

- нет-Бен-ссылки говорит НПМ , чтобы не создавать какие-либо символические ссылки. Нет способа (по моим сведениям) о переводе симлинки в папке Windows.

+502
fazil tm 10 окт. 2012 г., 02:49:59

Похоже, что Ubuntu-рабочий стол и другие важные пакеты (пакет GNOME-апплеты в GNOME-сессия) будет удаляются путем удаления вино таким образом.

Чтобы переустановить их в терминале, выполните команду sudo apt-получить установку Убунту-десктоп

+492
Cetagan 25 июн. 2015 г., 19:55:34

Стальной Шторм

Стальной шторм старой школы сверху вниз аркадная стрелялка со счетом ориентированной конкурентоспособной геймплей, и предназначен для людей, которые любят быстрый темп действий и имеют ограниченное количество времени, чтобы играть в компьютерные игры.

События происходят в альтернативной вселенной, где вы управляете продвинутый танк, упакованные с самым передовым и современным оружием. Ваша задача проста, но, тем не менее, не является тривиальным. В борьбе с предполагаемыми внеземными захватчиками, ты должна восторжествовать!

alt text

+481
shibashish mukherjee 9 сент. 2012 г., 07:24:06

Да, из терминала:

суда apt-получить установку индикатора-погода

Или доступны через Центр приложений Ubuntu:

индикатор-погода Install indicator-weather

+386
suman pinnamaneni 27 сент. 2017 г., 22:13:14

Жесткую связь не указатель на файл, это запись каталога (файла), указывающую на тот же индексный дескриптор. Даже если вы измените имя файла жесткую связь по-прежнему указывает на файл. Если вы замените другой файл с новой версией (путем копирования), жесткую связь не будет указывать на новый файл. Вы можете только иметь жестких ссылок в той же файловой системе. С жестких ссылок у вас нет понятия исходные файлы и ссылки, все равны (думаю, это как ссылка на объект). Это очень низкий концептуальный уровень.

С другой стороны, символическая ссылка указывает на другой путь (имя файла); он решает имя файла каждый раз, когда вы открыть его через симлинк. Если вы переместите файл, символическая ссылка не последует. Если вы заменить файл на другой, сохраняя имя, символическая ссылка будет указывать на новый файл. Симлинки могут файловые системы пядь. С симлинки у вас есть очень четкое различие между фактическим файла и символьной ссылки, который хранит никакой информации у тропинки о файле, на который он указывает.

+385
Chirag Vyas 10 февр. 2012 г., 09:53:58

Решение: покупка нового аккумулятора или пусть ремонт ноутбука по гарантии. Теперь это происходит каждый раз, и это ничего, относящегося к Ubuntu. Поэтому, пожалуйста, голосовать за закрытие.

Кстати: я постараюсь некоторые другие вещи в понедельник. Но по всему то этот ответ единственный подходящий ответ.

+328
Johhny Blue 3 сент. 2015 г., 15:25:38

Там, вероятно, не будет никаких проблем, но убедитесь, что и резервное копирование всех важных файлов в Win 8 первых. Windows 8 имеет хорошую двойную менеджер загрузки, так как пока вы не формат или что-нибудь переписать, я не думаю, что вы будете иметь проблемы. У меня есть двойной загрузки Windows 8 и XP без каких-либо проблем.

+310
ARMI 29 июл. 2015 г., 02:19:16

У меня Acer ноутбук и установил Vista на нем (успешно), но не могу получить мои новые установки Ubuntu 10.4 беспроводное соединение с интернетом. Я могу получить список маршрутизаторов (на треугольная кнопка) и он пытается его трудным для подключения, но без результата. "Дополнительные драйверы" установленных в системе Ubuntu 10.4-находится в "приложения" -- поврежден, так что не поможет. Я тщетно пытался искать драйвер в интернете, но не мог найти ничего. Пожалуйста, помогите мне подключиться к интернету с правильным водителем. ([email protected])

+257
Virender 18 окт. 2017 г., 21:35:52
  1. Введите о:конфигурации в адресную строку, затем нажмите кнопку "я буду осторожен, я обещаю!" кнопки.
  2. Введите черный список в "фильтр" текстовое поле, а затем дважды кликаем на "расширения.черный список.включитьзапись", поэтому его значение изменяется на "ложные".
  3. Перейдите в инструменты -> надстройки, потом Плагины. Включите Java-плагин, если он отключен.
+191
Andrew Button 7 нояб. 2013 г., 19:41:24
  1. скопируйте файл на рабочем столе (для удобства)

  2. Щелкните правой кнопкой мыши на файл и выбрать Свойства

    enter image description here

  3. В разделе Разрешения установите флажок Разрешить выполнение файла как программы

    enter image description here

  4. дважды щелкните на файл и выбрать запустить в терминале, если это не GUI программа)

    enter image description here

По умолчанию файловый менеджер не может показать эту опцию и откройте файл в gedit вместо. В этом случае изменить настройки файлового менеджера в: правка-> параметры -> поведение чтобы "спрашивать каждый раз" или сразу "запускать исполняемые файлы"

Командной строки

компакт-диски /путь/к/файлу
чмод +х filename.sh
./filename.sh

Комментарий ниже, если это не будет работать :)

Если все равно не работает, несмотря на то, что разрешить выполнение файла как программы тикали, когда вы дважды щелкните на .файл sh, и он запускает команду gedit, перейдите в папку со скриптом.

Как только вы находитесь в правильном текущую папку для скрипта, вы можете запустить скрипт вроде этого:

судо ./filename.sh

Если это не сработает, вы можете попробовать

судо Баш filename.sh

От раздела fat

Следовать этому как выполнить файл с fat USB-накопитель?

+184
Katya 10 мар. 2014 г., 00:31:00

Экстремальные нуб здесь, так, пожалуйста, мне точку в направлении для начинающих!

Мне удалось подключить Box.net учетную запись, следуя этим инструкциям.

Однако, когда я скопировать файлы и вставить их в файл в окно, я получаю доступ запрещен сообщение об ошибке. Потом попробовать снова, и это позволит мне двигаться. Однако это продолжает происходить и делает пакетный движения невозможно.

Любая помощь будет высоко оценили.

+170
CiTuX 25 мар. 2013 г., 16:09:50

Во-первых, установить xautomation:

судо apt-получить установку xautomation

Вы можете послать средней кнопки мыши события, используя хте:

хте 'кости 2'

Вы можете создать пользовательский ярлык в Параметры -> комбинации клавиш (или сочетания клавиш' от поиска единства). Нажмите кнопку "Добавить", введите имя и команду выше и нажать кнопку "Применить". Прокрутите вниз и установите ярлык, как вы бы для любого другого действия.

Когда я попытался это, я не смог привязать действие к просто клавишу Windows. Вы можете попробовать его, выполнив следующие действия, но там, кажется, ошибка, которая мешает работать:

Откройте терминал и выполните

gconf редактор

Нажмите сочетание клавиш Ctrl+F и выберите Поиск также в поле ключевых ценностей и введите следующее в поле поиска:

хте 'кости 2'

Там должен быть только один результат на нижней панели. Если есть больше, выберите тот, который содержит '/рабочий стол/гном/назначения клавиш/таможня*/действий от его имени. В верхней правой панели введите " (без кавычек) рядом с 'привязкой' поле. Если вы получите тот же результат, что я делал, все окна внешность изменится, а новый даже не будет ничего делать. Изменить это обратно каким бы он ни был (или сделать его пустым) и открыть внешний вид (Настройки -> Внешний вид или "внешний вид" под поиск "единство"). Это должно исправить проблему.

+151
Michael Louth 30 авг. 2015 г., 20:33:39

Это хороший вопрос, и вики-страницы большинство людей ( https://help.ubuntu.com/community/WifiDocs/WirelessCardsSupported) устарела и информация, переданная пользователем, что иногда ошибочные, кажется.

Эти страницы являются хорошим местом для начала, хотя они, вероятно, более полезно, если вы имеете команду lspci информация в руки. (Предыдущий опыт показывает, что некоторые карты с одинаковым названием модели содержат разные чипсеты!)

http://wireless.kernel.org/en/users/Documentation/FAQ

http://wireless.kernel.org/en/users/Devices/USB

Я тоже в поисках подобной карты, и хотелось бы услышать личные рекомендации, в том числе от экспертов в Ubuntu с USB беспроводной-N устройство безотказно работает из коробки (и на N-скорости, а не г-скорости) в 10.04 и позже.

+139
boucekv 9 февр. 2015 г., 19:51:10

Исправлена...

(Но я не уверен, почему!)

Я следовал этим инструкциям , чтобы переустановить драйверы, и перезагружается.

Ничего не изменилось.

Потом я пошел в дополнительных драйверов и поддержкой нуво (который я уже включается и отключается несколько раз, и которая должна быть включена здесь)... и тогда я получила 3D После того как я перезагрузил.

+136
fandev 5 мая 2012 г., 03:39:28

Reflap велик скайпу альтернативы нет. Это веб-основе, так что вам не нужно ничего скачивать, и вы можете совершать бесплатные видео звонки любому вашему выбору легко. Плюс вы получаете адрес вызова, который будет служить ваш номер телефона, что позволяет любому, чтобы позвонить вам, когда ваш доступен.

+128
Sibiriachka 31 мар. 2019 г., 03:45:35

Да, вы хорошо идти с TrueCrypt.

В случае, если вы хотите зашифровать весь системный диск вы должны обратиться это руководство http://jan-krueger.net/development/truecrypt-system-drive-on-linux

+101
Gyonder 16 мар. 2018 г., 13:27:56
  1. Скачать

    Что я обычно делаю это загрузить флеш-плеер от Adobe с сайта (так как я использую 64-битную систему, я скачать 64-битный плагин).

  2. Экстракт пакет

    Затем, в терминал, запускаем Наутилус gksudo.
    Распакуйте архив, нажав правой кнопкой мыши на скачанный дистрибутив и выбрав "извлечь". Введите папку, и вы найдете файл libflashplayer.так.

  3. Скопировать файл libflashplayer.так что в любой:

    • в /usr/lib в/в Firefox-аддонов/плагинов (для Firefox)
    • /УСР/Либ/хром-браузер/плагин (для Хрома)

Что это!

+75
James Hawley 23 сент. 2011 г., 07:55:10

Node.js это платформа, построенная на время выполнения JavaScript в Chrome для упрощения построения высокопроизводительных масштабируемых сетевых приложений. Node.js использует событийно-ориентированный и неблокирующий модель ввода-вывода, что делает его легким и эффективным, идеально подходит для ресурсоемких приложений реального времени, которые работают в распределенных устройств.1

Установка

Node.js может быть установлен с помощью трех основных методов на Ubuntu и ее производных.

Через АПТ

Первый способ-это через apt (или переднего, Центр приложений Ubuntu), выполнив:

судо apt-получить установку nodejs

проблема, однако, заключается в том, что Node.js установленных таким способом, как правило, очень устарели.

Через apt, скручиваются и nodesource

Поочередно, Node.js может быть установлен через запуска:

судо apt-получить установку -й завиток
завиток -сл https://deb.nodesource.com/setup_0.12 | судо Баш -
суда apt-получить установку -г nodejs

Версия обеспеченные через этот метод, как правило, в курсе и даже если это не это, как правило, только устаревшие на несколько дней. Эта установка будет автоматически обновляться всякий раз, когда выполняется обновление программного обеспечения.

От источника

Если один требует самую последнюю версию, или другую версию, которая не доступна на любом из этих двух методов можно установить из исходных кодов. Это, как правило, наиболее трудоемкие методы, потенциально занимает более часа, в зависимости от платформы, хотя большинство это автоматизирована и требует очень мало вмешательства пользователя. Чтобы получить исходный код можно пойти в http://nodejs.org/dist/, чтобы найти URL-адрес для выхода они хотят (что http://nodejs.org/dist/latest/node-$ver.tar.gz на последнем релизе, где $Вер заменяется на последнюю доступную версию с буквой в перед ним, например, $Вер=версии v0.12.7 для версия 0.12.7). Можно скачать этот релиз с одного веб-браузер, через , с помощью или через любой менеджер закачек можно было бы лучше. Для простоты следующий код предполагает одно скачивание архива для Node.js версия 0.5.1+ с помощью команды wget, в этом случае код (запускать из каталога, в котором вы хотите, чтобы исходный код скачать):

#Установить зависимости; при установке Node.js 0.6.х будут 
#необходима libssl-dev и
суда apt-получить установку сборки основных питона
#Настройки версии одной установкой, помню в!
Вер=версии v0.12.7
с wget -с http://nodejs.org/dist/$Вер/узел-$ver.tar.gz
тар-узел с официального сайта-$ver.tar.gz
компакт узел-$Вер
./настроить
сделать
установка

обратите внимание, что в тар строке можно указать, где исходный код извлекается при желании (с помощью добавления -с destdir, в котором destdir, в место исходного кода), но если нужно регулировать в следующей строке на диск содержимое destdir. Эта установка может быть более гибким, чем ранее описанные методы, но он не будет автоматически обновлять себя. Вместо того, чтобы обновить источник установки нужно повторно запустить линии 5-10 с обновленной версии стоимость.

Если один ожидает обновление Node.js вручную часто (например, если кто-то хочет последний выпуск Node.js как только она выйдет) это может быть лучше использовать вместо того, чтобы получить исходный код. Хотя этот способ займет больше жесткий диск (HDD) пространство и имеет больший размер (>100 МБ), поэтому он рекомендуется только для тех, кто планирует регулярно обновлять свои установки Node.js .

Чтобы получить исходный код через Git и затем установить его работать:

суда apt-получить установки git #установка git
https://github.com/joyent/node.git git клон 
компакт узел
в Git дистанционного добавить вверх https://github.com/joyent/node.git
#Снова, замените это последний доступный релиз
Вер=версии v0.12.7
ГИТ выборки апстрим
ГИТ кассе $Вэр
./настроить
сделать
установка

потом обновлять установки запустите последние 6 строк (от Вер=версии v0.12.7 вниз) настоящего Кодекса, с обновленной версии стоимость.

Ссылки

  1. nodejs.org
+70
nana1326 11 февр. 2011 г., 01:29:54

Попробовать DeVeDe. Я экспериментировал немного с несколько вариантов и DeVeDe было лучшее, что я нашел. Он устанавливает некоторые компоненты KDE, но альтернативы гном не был так хорош.

+56
Saumya 8 авг. 2010 г., 23:51:58

Подключение как обычно (не беспокойтесь о других жалуются на невозможность подключения на данный момент). Теперь откройте терминал и введите команду ifconfig.

Он должен показать вам ваших сетевых устройств. Вы увидите Ло, как eth0, как wlan0, wlan1. Искать беспроводная локальная сеть , которая на самом деле имеет IP-адрес...это тот самый, что вы хотите сохранить.

Поэтому, если wlan1 имеет IP, то мы хотим избавиться от как wlan0.

Теперь, типа:

судо нано /etc/файл RC.местные

и прокрутите вниз до самого дна, а чуть выше "выход 0", Тип

судо команду ifconfig как wlan0 вниз 

Нажмите сочетание клавиш Ctrl+Х, затем введите для сохранения и выхода. После перезагрузки, он должен снять как wlan0 интерфейс (сетевую карту вы не хотите), как она начинается.

Если позже вы решите, что вы хотите это выключить, просто стереть эту строку.

+47
xornob 23 окт. 2017 г., 18:01:53

Показать вопросы с тегом